DS Lites (Yellow Screen)

Discussion in 'Electronic Games' started by Mew, Oct 29, 2007.

  1. Mew

    Mew New Member

    KK, so on all the shipments of 2007 DS lites, the touch screen has a lite yellow tent to it. It is another layer meant to protect the screen for a longer period of time.

    Okay, so I'm getting a lite for Christmas, and I was wondering how ugly is it? I've also heard that it is a little less responsive to your touches.

    Anyone have one of these?
     
  2. aade8

    aade8 New Member

    I do, and when I first played on it, I thought I got a defective DS, but I guess not. You are correct, it seems that it takes a double-take sometimes to ensure that you actually 'click' the screen. Overall, though, once you get used to it, it really doesn't make a difference.
     
  3. bullados

    bullados <a href="http://pokegym.net/forums/showthread.php?

    Really? My DSL is 07 vintage, and I don't see much of a problem with the lower screen. MUCH better than my DSPhat, brighter, sharper, all that jazz...
     
  4. gallade

    gallade New Member

    my friend dosnt notice, his was a 07 shipment
     
  5. Regis_Neo

    Regis_Neo Moderator

    It has a yellow screen? Meh...I guess I'll wait for the next gen DS to (eventually) come out and just stick with good old original DS for now.
     
  6. Mew

    Mew New Member

    It's there, but I looked at my friend's a couple days ago, and it's really not that noticable.
    Afte you play with it for 5min, you never notice it again.
     
  7. Skarmbliss

    Skarmbliss New Member

    i have a small blue little dot on my top screen when the game is on.
     
  8. homeofmew

    homeofmew Active Member


    that's a pixel defct you can get those fixed if you want :)
     
  9. Azure Kite

    Azure Kite New Member

    I don't know what shipment mine was (I got it in Feb 07 so it was probably 07 shipment and not 06 since it was right after Christmas and Lites would probably be all sold out if they were 06 shipment)but I have never noticed any kind of defect with mine. There could just be a manufacturing error and some of the Lites shipped out got it and some didn't. Who knows maybe I'm a lucky one.:cool:
     

Share This Page